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Copyright Notice

Copyright © 2008-2022 MOHR Test and Measurement LLC (MOHR). All rights reserved.

Reproduction of this manual in print and electronic form is authorized for U.S. Government
purposes only. This manual may not be reproduced, distributed, transmitted, displayed, published,
or broadcast in any form or medium by any other party without written permission from MOHR.

MOHR products are covered by U.S. and foreign patents, issued and pending. Information in this
publication supersedes all previously published material. MOHR reserves the right to change
product specifications or pricing at any time without notice.

This manual contains trademarks and material copyrighted or patented by MOHR and other third
parties. All marks, copyrights, trade secrets, and patents should be considered to be the property
of their respective owners and all rights are reserved. Nothing contained herein shall be construed
by implication, estoppels, or otherwise as granting to the user a license under any copyright,
trademark, patent, or other intellectual property right of MOHR or any third party. Statutory
notice contained herein represents trademark status in the United States.

MOHR Test and Measurement LLC, 2105 Henderson Loop, Richland, WA 99354 USA
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Manual Updates

We at MOHR are always working to improve the written materials we offer to our valued
customers. Since our last printing, there may have been minor updates to this manual.

To view our most recent manual revision, open the accompanying CT Viewer 2 DVD, or visit us
online at www.mohrtm.com. (Please click on Products, CT100, Downloads.)

Date Generated 2023.03.06
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Software License Agreement

1. This is an agreement between MOHR Test and Measurement LLC (“MOHR”) and Licensee,
who is being licensed to use the named Software.

2. Licensee acknowledges that this is only a limited nonexclusive license. MOHR is and remains
the owner of all titles, rights, and interests in the Software.

3. This License permits Licensee to install the Software on more than one computer system, as
long as the Software will not be used on more than one computer system simultaneously.
Licensee will not make copies of the Software or allow copies of the Software to be made by
others, unless authorized by this License Agreement. Licensee may make copies of the
Software for backup purposes only.

4. This Software is subject to a limited warranty. MOHR warrants to Licensee that the
physical medium on which this Software is distributed is free from defects in materials and
workmanship under normal use, the Software will perform according to its printed
documentation, and to the best of MOHR’s knowledge Licensee’s use of this Software
according to the printed documentation is not an infringement of any third party’s
intellectual property rights. This limited warranty lasts for a period of 90 days after delivery.
To the extent permitted by law, THE ABOVE-STATED LIMITED WARRANTY
REPLACES ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, AND MOHR
DISCLAIMS ALL IMPLIED WARRANTIES INCLUDING ANY IMPLIED WARRANTY
OF TITLE, MERCHANTABILITY, NONINFRINGEMENT, OR OF FITNESS FOR A
PARTICULAR PURPOSE. No agent of MOHR is authorized to make any other warranties
or to modify this limited warranty. Any action for breach of this limited warranty must be
commenced within one year of the expiration of the warranty. Because some jurisdictions do
not allow any limit on the length of an implied warranty, the above limitation may not apply
to this Licensee. If the law does not allow disclaimer of implied warranties, then any implied
warranty is limited to 90 days after delivery of the Software to Licensee. Licensee has specific
legal rights pursuant to this warranty and, depending on Licensee’s jurisdiction, may have
additional rights.

5. In case of a breach of the Limited Warranty, Licensee’s exclusive remedy is as follows:
Licensee will return all copies of the Software to MOHR, at Licensee’s cost, along with proof
of purchase. (Licensee can obtain a step-by-step explanation of this procedure, including a
return authorization code, by contacting Licensor at 2105 Henderson Loop, Richland, WA
99354 or 1-888-852-0408.) At MOHR’s option, MOHR will either send Licensee a
replacement copy of the Software, at MOHR’s expense, or issue a full refund.

6. Notwithstanding the foregoing, MOHR IS NOT LIABLE TO LICENSEE FOR ANY
DAMAGES, INCLUDING COMPENSATORY, SPECIAL, INCIDENTAL, EXEMPLARY,
PUNITIVE, OR CONSEQUENTIAL DAMAGES, CONNECTED WITH OR RESULTING
FROM THIS LICENSE AGREEMENT OR LICENSEE’S USE OF THIS SOFTWARE.
Licensee’s jurisdiction may not allow such a limitation of damages, so this limitation may not
apply.

7. Licensee agrees to defend and indemnify MOHR and hold MOHR harmless from all claims,
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losses, damages, complaints, or expenses connected with or resulting from Licensee’s business
operations.

8. MOHR has the right to terminate this License Agreement and Licensee’s right to use this
Software upon any material breach by Licensee.

9. Licensee agrees to return to MOHR or to destroy all copies of the Software upon termination
of the License.

10. This License Agreement is the entire and exclusive agreement between MOHR and Licensee
regarding this Software. This License Agreement replaces and supersedes all prior
negotiations, dealings, and agreements between MOHR and Licensee regarding this Software.

11. This License Agreement is governed by the law of the State of Washington applicable to
State of Washington contracts.

12. This License Agreement is valid without MOHR’s signature. It becomes effective upon the
earlier of Licensee’s signature or Licensee’s use of the Software.
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Contacting MOHR

Phone
+1-888-852-0408

Mail
MOHR Test and Measurement LLC
2105 Henderson Loop
Richland, WA 99354
USA

E-mail
Sales: sales@mohrtm.com

Technical Support: techsupport@mohrtm.com

Web
www.mohrtm.com
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1 Introduction

The CT Viewer™ 2 computer software allows users of the MOHR CT100B Time-Domain
Reflectometer (TDR) to transfer, view, and manipulate the cable scans that have been saved on
their instruments. This software package allows the user to select stored scans and view, compare,
and do a variety of mathematical transformations to any of the traces.

CT Viewer 2 also allows the user to create reports and print plots that can be imported into
word-processing or report creation software, to create files of traces suitable for transfer to others,
and to load trace files created by others.

1.1 Compatibility With the MOHR CT100 TDR

CT Viewer 2 is fully compatible with the older MOHR CT100, including connecting, transferring
traces, and remote control. Some instructions in this manual refer to menus on the CT100B.
Because the CT100B menu system differs from the CT100, these instructions may not apply to the
CT100.
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2 Installation and Setup

Installation requirements:

1. Windows Vista or newer
2. Microsoft .NET Framework 4.6 (included on the installation DVD)

2.1 Installing CT Viewer™ 2

Insert the CT Viewer 2 DVD into your DVD drive.

Figure 2.1 CT Viewer 2 installer package.

If auto-run is enabled, CT Viewer 2 will automatically launch the installer package (Figure 2.1). If
auto-run is disabled, the CT Viewer 2 installer package can be executed manually by clicking on
DVD-DRIVE\setup.exe (where DVD-DRIVE is the drive letter of the DVD drive).

Although the installer package suggests installing SQL Server 2012 Express before installing CT
Viewer 2, the SQL Server software is optional. It only needs to be installed if you previously used
CT Viewer 1 and would like to access databases you created while using that program. See
Section 2.2 for more information on installing the SQL Server software.

On the launcher, use the drop-down menu next to Operating System Type to select either 64-bit or
32-bit, depending on what type of operating system the PC has.
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2 Installation and Setup

Click on Install CT Viewer Software to begin installation.

The installer will try to install the USB drivers for the CT100B. Most computers will show a
prompt to approve the driver installation. If the driver installation is cancelled, CT Viewer 2 will
not be able to connect to the CT100B over USB.

The USB drivers can be installed any time after the installation. See Section 2.3.

After CT Viewer 2 is installed, you can install any optional components included on the DVD. See
Section 2.2.

The installer will place a shortcut to CT Viewer 2 on the desktop. Double-click on the icon to get
started. The icon should look similar to Figure 2.2.

Figure 2.2 CT Viewer 2 icon.

2.2 Installing Optional Components

By default, CT Viewer 2 will use any hardware video acceleration that is installed on the system.
For convenience, Microsoft DirectX 9.0c has been included on the installation DVD. If you wish to
install DirectX, click on Install DirectX 9.0c in the launcher window and follow the prompts.

If you wish to install SQL Server 2012 Express software for database access, click on Install SQL
Server 2012 Express. Follow the prompts and choose the default values. If the SQL Server software
successfully installs, you should be able to create databases to store traces in CT Viewer 2.

For administrators who want extra control over their SQL server install, SQL Management Studio
has been included on the installation DVD. Click on Install SQL Management Studio to install this
software.

2.3 Installing USB Drivers

USB drivers are typically installed automatically during CT Viewer 2 installation (Section 2.1).
The drivers can also be installed at any time using the following procedure.

Connect the CT100B to the computer by means of a standard A-B USB cable. Plug the B (square)
end of the cable into the back of the CT100B, and the A (rectangle) end of the cable into a USB
port on the PC. (The USB ports on the front of the CT100B are used for thumb drives,
keyboards, etc., not for connecting to your PC.)

Power on the CT100B and allow it to boot up completely.

Windows will detect that a new device is connected to the computer (Figure 2.3).
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2 Installation and Setup

Figure 2.3 After connecting the instrument via USB, Windows will suggest installing driver
software for the CT100B.

Note: A common problem with Windows is that it may be configured to not display the window
shown in Figure 2.3. If this happens, run the Device Manager software in Windows. The CT100B
will show up in the device manager window as a device with a question mark or exclamation point.
The symbol means that the driver is not yet installed. Right-click on the CT100B and select
Update Driver to continue with the driver installation.

Choose Locate and Install Driver Software to advance to the next step. At this time, insert the CT
Viewer 2 DVD into the DVD drive.

After inserting the CT Viewer 2 DVD and clicking the Next button, Windows will search the DVD
for the necessary files. After a successful search, Windows will prompt the operator to install the
driver. See Figure 2.4. To proceed to the next step, click on Install.

Figure 2.4 Windows security message for third party software.

To confirm the install, the final display should look similar to the one pictured in Figure 2.5.
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2 Installation and Setup

Figure 2.5 Windows has successfully installed the USB driver for the CT100B.

2.4 Updating CT Viewer

You should always be using the latest version of CT Viewer 2. If the computer running CT Viewer
2 is connected to the Internet, it may automatically check for updates when you start CT Viewer
2. You can also click on Help then Check for Updates to see if you are running the latest version.

If CT Viewer 2 finds that there is a newer version of the software available, it will launch an
update window (Figure 2.6). This window lists the updates made to CT Viewer 2.
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2 Installation and Setup

Figure 2.6 When CT Viewer 2 can be updated, it will launch an update window.

Click on Install Update. CT Viewer 2 will download the update. Then click Install and Relaunch
and follow the prompts. You will now be using the latest version of CT Viewer 2.

If the computer running CT Viewer 2 cannot connect to the Internet, and you would like to install
the most recent version of CT Viewer 2, contact MOHR for an installation DVD.
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3 Connecting to the CT100B

3.1 Connecting the CT100B to CT Viewer 2 via USB

USB drivers are usually automatically installed with CT Viewer 2. But they can be installed at
any time using the steps in Section 2.3. If USB drivers are installed, connecting the CT100B to CT
Viewer 2 via USB is a quick process.

Double-click on the CT Viewer 2 icon on the computer desktop to get started. Connect the
CT100B to the computer using a standard A-B USB cable. Plug the B (square-shaped) end of the
cable into the back of the CT100B, and the A (rectangle-shaped) end into the PC. This can be
done before or after you turn on the CT100B.

Before the USB cable is plugged in, CT Viewer 2 will have a button saying Find Tester
(Figure 3.1). Find Tester should automatically change to Open Tester once the USB cable is
plugged in and the CT100B is turned on (Figure 3.2).

Figure 3.1 The Find Tester command appears as on on-screen button and in the File menu.

Figure 3.2 Once you’ve successfully connected to the CT100B, the Open Tester command
appears as an on-screen button and in the File menu.

If it doesn’t change, click on Find Tester and CT Viewer 2 will connect to the CT100B and bring
up a transfer dialog window listing the collection of traces on the CT100B (Figure 3.3). In the
transfer dialog window common commands are available via buttons (Table 3.1).
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3 Connecting to the CT100B

Figure 3.3 Transfer dialog window showing traces stored on the CT100B. The trace named
“screen” is selected.

Table 3.1 Commands in the transfer dialog window
Button Command
Transfer To Copy the selected traces to the computer. See Section 3.5 for more details.

Select All Select the entire collection of traces available on the CT100B.

Delete Delete the selected traces from the CT100B. This removes them
permanently. This option can take some time.

3.2 Connecting the CT100B to CT Viewer 2 via Ethernet

An alternative approach is to connect the CT100B to the computer by means of an Ethernet cable.
This allows long distance control and transfer of files.

Plug an Ethernet cable into the back panel of the CT100B and connect the cable to the network.
Allow the CT100B to boot up completely. Double-click on the CT Viewer 2 icon on the desktop of
your PC.

You can use either CT Viewer 2 or the CT100B to connect to each other via Ethernet. There are
different steps for each connection.

3.2.1 Using CT Viewer 2 to Connect to the CT100B

In CT Viewer 2 click on the Find Tester button. This will bring up a dialog box listing a potential
CT100B connection and a spot where you can manually enter an IP for the CT100B (Figure 3.4).
To find the CT100B’s IP address, press the blue MENU button, then Settings, then Network
Settings, then Show IP Config (Figure 3.5). In CT Viewer 2, either choose OK under the potential
connection or type in the IP address and click Use Manual Entry.
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3 Connecting to the CT100B

Figure 3.4 The Find Tester dialog box.

Figure 3.5 The CT100B’s IP address.

If you have successfully connected to the CT100B, the Find Tester button should have changed to
Open Tester and CT Viewer 2 will display a message that a CT100B has connected to it with the
IP address of the CT100B (Figure 3.6).

Figure 3.6 The message displayed by CT Viewer 2 when a CT100B connects.

You can now open the tester in CT Viewer 2 using the Open Tester button or File → Open Tester.
See Table 3.1 for an explanation of the commands available when you use Open Tester. You can
also start a Remote Control session. See Section 6 for more information about Remote Control.
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3 Connecting to the CT100B

3.2.2 Using the CT100B to Connect to CT Viewer 2

Press the blue MENU button on the CT100B to open the Main menu. See Figure 3.7.

Figure 3.7 The Main menu of the CT100B.

Select Connect to CT Viewer on the CT100B. A menu with connection options appears along the
bottom of the CT100B’s screen (Figure 3.8).

Figure 3.8 The CT Viewer connection menu on the CT100B.

Select Find CT Viewer on the CT100B, and the CT100B will scan for servers and will either
automatically connect to a server if there is only one available or bring up a list of detected servers
to choose from.

Use the M-FUNCTION knob to choose a PC, and press the Select button. If the PC you wish to
connect to is not in the list, choose Cancel to go back to the previous screen so that you can
manually connect to CT Viewer 2.

If you select Manual Connect, the Select PC dialog box will appear (Figure 3.9).
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3 Connecting to the CT100B

Figure 3.9 The Select PC dialog box containing three different PCs in the list.

Use the M-FUNCTION knob to choose a PC and press the Select button. If the PC you wish to
connect to is not in the list, choose Add PC to add it.

To find the address of the PC running CT Viewer 2, go to File → Ethernet Configuration in CT
Viewer 2 (Figure 3.10). A window will appear that will list the address or addresses of that PC.
Enter that information into the Add PC dialog box on the CT100B (Figure 3.11).

Figure 3.10 Using CT Viewer 2 to find the IP address of the PC.

Figure 3.11 After selecting Add PC, enter the information for the PC into this dialog box.
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3 Connecting to the CT100B

CT Viewer 2 will display a message that a CT100B has connected to it. You can now open the
tester (File → Open Tester) or start a Remote Control session.

3.3 Installing a CT100B License File

Depending on how it was purchased, the CT100B may be supplied with either a 30-day
demonstration license or permanent license. Current license information can be found on the
CT100B by navigating to Settings → Info → License → License Info.

If the CT100B came with a permanent license already installed, no new license installation is
necessary. If your CT100B has a license with a pending expiration and you are unsure how to
upgrade to a permanent license, contact MOHR. MOHR will email you a permanent license file.
Save the license file to your computer before attempting to install it on the CT100B.

Connect the CT100B to the computer by means of a USB or Ethernet cable. Power on the
CT100B and allow it to boot up completely.

Connect the CT100B to CT Viewer 2. For assistance, see Section 3.1 and Section 3.2.

Once a successful connection has been made, click on Help, then Install License.

Browse to the location of the saved license file and select it. The CT100B will display a message if
the license file was installed successfully.

3.4 Updating the CT100B

Connect the CT100B to the computer by means of a USB or Ethernet cable. Power on the
CT100B and allow it to boot up completely.

In CT Viewer 2, click on File then Open Tester (Hotkey: Ctrl-F).

The transfer dialog window will appear and list the collection of traces on the CT100B.

If there is an update available, CT Viewer 2 will prompt the operator to update the CT100B
(Figure 3.12). Generally, you should always be running the latest versions of CT100B and CT
Viewer software. See Section 2.4 for information about updating CT Viewer 2 software.
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3 Connecting to the CT100B

Figure 3.12 CT Viewer 2 has detected that there is an update available for the CT100B.

The update process of the CT100B is tracked via a progress bar. CT Viewer 2 will prompt the
operator when the update is complete. The operator should reboot the CT100B and reconnect it
with CT Viewer 2 after the reboot.

3.5 Copying Traces From a CT100B to the Computer

1. Connect the CT100B to the computer by means of a USB or Ethernet cable. Power on the
CT100B and allow it to boot up completely.
Note: If the CT100B is connected by an Ethernet cable, refer to Section 3.2 for instructions
on how to connect CT Viewer 2 to the CT100B over Ethernet.

2. In CT Viewer 2, go to the File menu and choose Select Default Trace Folder. Select or create
a folder to store your trace files.

3. In CT Viewer 2, click Open Tester (Hotkey: Ctrl-F). A transfer dialog window will appear
and list the collection of traces available on the CT100B.

4. Select the desired traces. To select multiple traces, either hold down Ctrl while selecting each
trace or hold down Shift to select neighboring traces.

5. Click on the Transfer To button. A dialog box should appear (Figure 3.13).

Figure 3.13 The Transfer To dialog box for copying traces to a computer.

6. Verify that the checkbox next to Send Traces to Database is not checked.
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3 Connecting to the CT100B

7. Verify that the destination folder is correct and then click Start Transfer.

Once the selected traces are copied from the CT100B, they will load onto the CT Viewer 2 screen.
CT Viewer 2 scales loaded traces to fit vertically, covering at least five divisions (Figure 3.14).

Figure 3.14 A trace copied from the CT100B.

3.6 Copying Traces From a CT100B to a Database

Using a database to store your traces is optional. It is only recommended for users who previously
used CT Viewer 1, stored traces in a database, and who would like to still be able to access those
traces. Only simple saved traces can be transferred to a database. If other trace types, such as
derivative or difference traces, need to be transferred from the CT100B to CT Viewer 2, see
Section 3.5. See Section 8 for information on configuring a database.

1. Connect the CT100B to the computer by means of a USB or Ethernet cable. Power on the
CT100B and allow it to boot completely.
Note: If the CT100B is connected by an Ethernet cable, refer to Section 3.2 for instructions
on how to connect CT Viewer 2 to the CT100B over Ethernet.

2. Click on Open Tester (Ctrl-F).
3. A transfer dialog window will list the collection of traces available on the CT100B.
4. Select the desired trace on the list. To select multiple traces, either hold down Ctrl while

selecting each trace or hold down Shift to select neighboring traces.
5. Click on the Transfer To button.
6. Make sure the box next to Send Traces to Database is checked (Figure 3.15).
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3 Connecting to the CT100B

Figure 3.15 The Transfer To dialog box for copying traces to a database.

7. Verify the SQL server and database are correct; otherwise, change the SQL server and
database using the drop-down menus.

8. Once a SQL server and database have been selected, an operator can start the transfer
process by clicking on the Start Transfer button.
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4 User Interface and On-Screen Menus

4.1 User Interface Overview

In Figure 4.1, we can see a sample workspace with three traces loaded.

Figure 4.1 A sample workspace with three traces. The numbers on the figure correspond
with the numbers below.

1. The ruler at the top is drawn using the units defined by the user. Figure 4.1 displays the
horizontal units in meters.

2. On-screen menu buttons are available for quick access to common commands.
3. Names of current loaded traces are displayed. The currently selected trace is drawn in red

and the label is also red and in a slightly larger font than the other traces.
4. The current scaling information for the selected trace is shown at the bottom left of the

display.
5. The velocity of the pulse and the name of the currently selected trace are displayed at the

bottom center of the window.
6. The Information Box/Cursor Measurements window at the bottom right shows the X-value

(distance) in meters (or current horizontal units) and nanoseconds, and Y-value in millirho
and ohms at each cursor.
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4.2 Tabs

CT Viewer 2 has workspace tabs (Figure 4.2). These allow for the user to have multiple
independent workspaces each with their own individually loaded traces and history.

Figure 4.2 Multiple open workspace tabs.

1. To create a new workspace tab, click on the yellow New Panel icon found to the right of the
workspace tabs. This will add a new tab to CT Viewer 2 where a user can load additional
traces.

2. To close a workspace tab, click the X icon on the workspace tab. Note: It is not possible to
recover a tab once it has been closed.

4.3 On-Screen Buttons and Tools Menus

The following functions assume that the operator has loaded a few traces onto the CT Viewer 2
workspace. Use Figure 4.1 as a base figure image for the following sections. Functions of on-screen
buttons (Figure 4.3) can also be accessed through the Tools menu.

Figure 4.3 On-screen buttons.

There is a Tool drop-down menu that can be used to access some of these commands, as well as a
“floating” window that contains a list of commands. See Figure 4.4.
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Figure 4.4 From left, the Tools menu, the Tool drop-down menu, and the Tools floating
window.

4.3.1 Reset X

Selecting Reset X (Reset X Offset in the Tools menu) will restore the X-offset for the selected trace
to zero. Figure 4.5 shows the selected trace has been shifted to the right 0.55 meters. The offset is
displayed next to the trace label. The Reset X button will put it back to the 0 offset position as
shown in Figure 4.1.

Figure 4.5 The selected cable has been moved 0.55 meters right from its original position.
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4.3.2 Reset Y

Selecting Reset Y (Reset Y Offset in the Tools menu) will reset any relative changes done on the
Y-axis (millirho) of the selected trace to zero. Figure 4.6 shows that the selected trace has been
moved up on the display. Reset Y will restore it to its original position as shown in Figure 4.1.

Figure 4.6 The selected trace has been moved upward from its original Y-offset.

4.3.3 Adjust X, Y Offsets

The Adjust X, Y Offsets menu selection allows the user to set specific X and/or Y offsets or ohms
at cursor for the selected trace (Figure 4.7). Changing the Y offset affects ohms at cursor and vice
versa.

Figure 4.7 The Adjust X, Y Offsets dialog box.
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4.3.4 Vert Re-Center at Cursor Location

The Vert Re-Center at Cursor Location menu selection moves the trace vertically so that the
cursor/trace intersection is centered.

4.3.5 Find Cursor

Clicking the Find Cursor button will swap the active and inactive cursors. If the newly active
cursor is off-screen, the view will be re-centered on that location. Use Find Cursor repeatedly to
jump back and forth between two locations.

4.3.6 Set Cursor

Clicking Set Cursor gives you a dialog box to enter specific X-ruler coordinates for the two cursors
(Figure 4.8).

Figure 4.8 The Set Cursor dialog box.

4.3.7 Reset Cursor

Clicking Reset Cursor will move cursors into the view region if they are off-screen.

4.3.8 Fit Trace

The Fit Trace button automatically changes the offset and X- and Y-scales so that the selected
trace will fit in the entire workspace. It is most useful to restore an overview of a trace after
zooming in to look at details. For example, Figure 4.9 shows a zoomed-in view. Clicking on Fit
Trace will restore the horizontal and vertical scales so that the entire trace fits in the window
again. Figure 4.10 shows the same traces after the Fit Trace command was used.
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Figure 4.9 The view region is zoomed in so only part of the selected trace is visible.

Figure 4.10 Window after Fit Trace was executed.

4.3.9 Fit Vertical, Vertical Fit Only

The on-screen button for this function is Fit Vertical. It is also found under the Tools window as
Vertical Fit Only. Choose Fit Vertical to re-scale selected traces so that they fit vertically on the
screen.

4.3.10 Fit Cursors

Selecting Fit Cursors zooms in the window horizontally to display only the region between the
cursors.
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4.3.11 Match V-Scale

The Match V-Scale menu selection changes all selected traces’ vertical scale to match the scale of
the primary selected trace and lines them up. See Figure 4.11 for an example.

Figure 4.11 The Match V-Scale command changes each selected trace’s vertical scale to
match the primary selected trace (red).

4.3.12 Select

(Hotkey: Tab)

The Select button selects the next trace in the list. Repeatedly choosing Select will cycle through
all of the visible traces.

Alternatively, click on a trace name in the Trace List sub-window, shown in Figure 4.12. Open the
Trace List sub-window by selecting Window → Traces from the menu bar.

Figure 4.12 Trace List sub-window.
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4.3.13 Select All

(Hotkey: Ctrl-A)

The Select All button selects all traces visible on the display. The primary selected trace will be
highlighted in red while secondary selected traces will be highlighted in teal (Figure 4.13).

Figure 4.13 The Select All command selects every trace in the workspace.

If all traces are selected, the Deselect All button or menu item can be clicked to deselect all the
traces. Or you can press the Escape key to deselect all traces (Figure 4.14).

Figure 4.14 Press the Escape key to deselect every trace.
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4.3.14 Set Trace Color

Select any trace or traces, then choose Set Trace Color. A window for picking colors will appear
(Figure 4.15). Use this window to change the color of the selected traces.

Figure 4.15 The window for selecting trace color.

4.3.15 Hide, Show All

The Hide button hides the selected traces from the display but keeps them in the workspace. Use
Show All to redraw them on the screen. The Visible checkbox in the Trace List sub-window shows
the visibility status of each trace (see Figure 4.12). Click on the check box to hide or show a
trace.

4.3.16 Remove

(Hotkey: Delete)

Clicking the Remove button removes the selected traces from the workspace. This will not delete
them from permanent storage (either disk files or database).

4.3.17 Pan

Found on all the Tool menus. When Pan is selected, clicking the background and dragging with
the mouse will move traces, cursors, etc. This is the default tool for the mouse.

4.3.18 Selection Box

Found on all the Tool menus. Choose Selection Box, then drag over a region of the screen. Traces
inside the region will be selected.
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4.3.19 Zoom Box

Found on all the Tool menus. Choose Zoom Box, then drag over a region of the screen. CT Viewer
2 will zoom in on that region.

4.3.20 Set Vp

The field for setting the Vp can be displayed by clicking on the Vp button (Figure 4.16).

Figure 4.16 The field for setting the Vp.

Type a new Vp setting and click the Set button to set the Vp for the selected trace. The horizontal
scale and cursors will be redrawn using the new value.

4.4 Window Menu

CT Viewer 2 has several on-screen windows than can be turned on and off under the Window
menu (Figure 4.17). Some of them, like the Tools window, can act as shortcuts to functions that
are also found in the drop-down menus. Others provide additional functionality to CT Viewer 2.
These windows are explained in the following sections.

Figure 4.17 The Window menu.

The Tools, History, Traces, and Trace Minimap windows can easily be moved anywhere within the
CT Viewer 2 workspace or even outside the main CT Viewer 2 window by clicking and dragging
them with the mouse.

The Information Box window is typically located in the bottom right of the screen, though it can
be moved by clicking the red square at the bottom right of the box and then clicking and dragging
with the mouse. Clicking the red square again will move the box back to the bottom right.
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4.4.1 Reset Windows Location

Clicking the Reset Windows Location button in the Window menu will reset visible on-screen
windows to their default locations.

4.4.2 Tools Window

The functionality of the Tools window can be found in Section 4.3.

4.4.3 History List Window

The History List displays a list of all the actions performed in the current workspace (Figure 4.18).
By clicking the undo and redo buttons at the bottom of the History List, the user can reverse or
repeat actions. The user can also use Ctrl-Z and Ctrl-Y to reverse or repeat actions.

Figure 4.18 History List window.

Left-clicking on any action in the History List will undo all actions up to that point.

4.4.4 Trace List Window

The Trace List displays a list of all traces that are currently loaded into the active workspace,
indicating if the trace is visible on-screen, the type of trace, and the trace’s name. In addition, X
and Y offsets for traces will be displayed if that option is selected in the Trace Label section of the
View menu. The primary selected trace will be highlighted in red and any secondary selected
traces will be highlighted in teal (Figure 4.19).
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Figure 4.19 Trace List window.

The user can select traces within the Trace List by left-clicking on any individual trace or by
clicking the up or down arrows at the bottom of the Trace List.

Holding down the Shift key and left-clicking on an unselected trace will select all the traces
between the unselected trace and the primary selected trace.

Holding down the Ctrl key and left-clicking on a trace will select and unselect traces in addition to
the primary trace.

By checking and unchecking the box in the visible column, the user can show or hide the associated
trace in the workspace.

4.4.5 Information Box/Cursor Measurements Window

The Information Box window at the bottom right of the screen displays cursor measurements for
the selected trace in the chosen horizontal and vertical units (Figure 4.20). Measurements for the
active cursor are displayed in red with stars next to them. Other measurements in the box are for
the inactive cursor as well as the relative distance, relative time, relative reflection coefficient, and
relative impedance. The Information Box can also display standard deviation and voltage standing
wave ratio (VSWR). See Section 5.11.5 and Section 5.11.6.

Figure 4.20 The Information Box window displays cursor measurements for the selected
trace.

4.4.6 Trace Minimap Window

The Trace Minimap shows a mini version of the entire selected trace. The part of the trace that is
visible on-screen is highlighted in a teal box on the minimap (Figure 4.21).
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Figure 4.21 The Trace Minimap window shows a mini version of the entire selected trace
and highlights the part of the trace visible on-screen.

4.4.7 Hide All Windows

By clicking the Hide All menu item in Window, the user can hide all of the on-screen windows
except the Information Box/Cursor Measurement window. The Information Box can only be
hidden by unchecking it in the Window menu.
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5.1 Manipulating Traces on the Workspace

You can zoom in and out on traces, and move them left, right, up, and down to see details easier.
This section describes the keystrokes necessary to do these things. See Figure 5.1 for an example of
three loaded traces. For each of the following sections, use Figure 5.1 as a base image. Each of the
following figures depicts the screen after some operation.

Figure 5.1 A workspace with three traces displayed.

5.2 Changing the Viewpoint

To move all on-screen traces, use the W-A-S-D keys to move them up, left, down, and right
respectively (Figure 5.2 and Figure 5.3).

Select traces by left-clicking on them. To select more than one trace, hold down the Shift key and
click additional traces on the workspace.

To move only the selected trace(s), use the same W-A-S-D keys while holding down Shift
(Figure 5.4).

Alternatively, left-click and drag the mouse to move all on-screen traces in any direction. Hold
down Shift and left-click and drag the mouse to move the selected trace up and down
independently of other on-screen traces. Hold down Ctrl and left-click and drag the mouse to move
the selected trace left and right independently of other on-screen traces. Or hold down Ctrl and
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Shift and left-click and drag the mouse to move the selected trace in any direction independently of
other on-screen traces.

Figure 5.2 Use the D key to shift the view region to the right, revealing area on the left that
was previously hidden.

Figure 5.3 Use the S key to shift the view region down, revealing area on the top that was
previously hidden.
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Figure 5.4 Use Shift-S to move only the selected trace down relative to the other traces.

5.3 Changing the Vertical Scale

Select a trace by left-clicking on it. To select more than one trace, hold down the Shift key and
click additional traces on the workspace.

To decrease the vertical scale (zoom in), either scroll the mouse wheel up or press the – key. To
increase the vertical scale (zoom out), either scroll the mouse wheel down or press the + key.

5.4 Changing the Horizontal Scale

Any changes made to the horizontal scale affect all on-screen traces.

To decrease the horizontal scale (zoom in), press the Q key.

To increase the horizontal scale (zoom out), press the E key. See Figure 5.5 for an example. As
before, use Figure 5.1 as a base image for comparison.

The current X and Y scaling information is displayed at the bottom left of the workspace.
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Figure 5.5 Increasing the horizontal scale (zooming out) using the E key.

5.5 Printing a Screenshot

With CT Viewer 2 you can print a screenshot of the current workspace. To do this, click on File
and then Print (Hotkey: Ctrl-P). A print dialog will appear where you can select the printer to use
and adjust basic settings for printing.

Additionally, to print multiple loaded traces on separate pages, click on File and then Print
Individual Trace. A print dialog will appear that is used for all of the selected traces.

5.6 Exporting a Screenshot

Click on File then Export Screenshot (Hotkey: Ctrl-Alt-X). CT Viewer 2 will take a screenshot of
the workspace. A Save As dialog will appear for you to enter a name and choose a location and file
type to save the resulting image file (Figure 5.6).
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Figure 5.6 Save As dialog to save a screenshot.

5.7 Configuring Ethernet Settings

Click on File then Ethernet Configuration (Hotkey: Ctrl-E). This will display an Ethernet
configuration dialog box (Figure 5.7).

Figure 5.7 Ethernet options.

1. The IP addresses shown in Figure 5.7 are only an example. IP addresses listed in the dialog
box are for the machine running CT Viewer 2. You will need to enter one of the listed IP
addresses into the CT100B configuration to connect a CT100B to CT Viewer 2 using
Ethernet. For more information on connecting using Ethernet, see Section 3.2.

2. The port number displayed in the dialog box is the one that CT Viewer 2 will listen to for
incoming connections.

Usually you do not need to change these settings. If you do, enter the port number to use, select
whether to listen on the port, and press OK to accept the new settings.
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5.8 Loading Traces From Files

5.8.1 Set Default Trace Folder

Set Default Trace Folder in the File menu opens a window for selecting the default folder for
loading and saving traces. Each time the Open Trace command is used, it will begin in the default
folder.

Imported traces will be saved to the default folder.

5.8.2 Open Trace

Open Trace is used to load traces that have been transferred from a CT100B and stored as “.mohr”
files on your PC.

1. Click on File then Open Trace (Hotkey: Ctrl-O). See Figure 5.8. Open Trace will always start
in the folder selected using Set Default Trace Folder.

2. Select the file to load.
3. Click on Open. The trace contained in the file will be loaded onto the workspace.

Figure 5.8 The Open Trace (Hotkey: Ctrl-O) option can be found under the File menu.
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5.8.3 Envelope Plots

Envelope plots that have been saved as screenshots on the CT100B can be transferred to and
viewed on CT Viewer 2.

5.8.3.1 Copy Envelope Plots

Connect the CT100B to CT Viewer 2 via USB or Ethernet. For more information on connecting
CT Viewer 2 to the CT100B, see Section 3.1 and Section 3.2.

1. Click on File then Copy Envelope from Tester. A dialog box will appear. See Figure 5.9.

Figure 5.9 Dialog box for copying envelope plot screenshots.

2. Select the envelope plot to copy.
3. Click Copy. When the envelope plot has been copied to the default trace folder for CT

Viewer 2, it will be displayed in the bottom part of the dialog box. See Figure 5.10.
4. When finished with copying envelope plots, click Close.
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Figure 5.10 An envelope has been successfully copied to CT Viewer 2.

5.8.3.2 Open Envelope Plots

Envelope plot screenshots can be viewed in CT Viewer 2 once they have been copied to the default
trace folder.

1. Go to File then Open Envelope.
2. A list of envelope plot screenshots appears. Select the envelope plot to view and click Open.

The envelope plot will appear on-screen. See Figure 5.11.
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Figure 5.11 Viewing an envelope plot screenshot.

When finished with viewing the envelope plot screenshot, select Close.

5.8.4 Import .ZTP File to Trace Folder

Import .ZTP File to Folder is used to import the traces stored in a ZTP file to the default folder as
set by Set Default Trace Folder.

ZTP files are an older format that can store multiple traces in a single file. When ZTP files are
imported into CT Viewer 2, they are converted to .mohr files.

5.8.5 Open Other Files

Use Open Other Files to open other file formats, e.g., files from older CT100s or from EFPs
(another instrument manufactured by MOHR). Supported file formats include CSV, XML, CTV,
and CTM.

5.9 Saving Traces to a File

5.9.1 Save a Copy or Export
1. Import the desired traces onto the workspace.
2. Select a trace.
3. Click on File then Save a Copy or Export and enter a name.
4. Select a file format to save to. Supported file formats: mohr, CSV, XML.
5. Click on Save.
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5.9.2 Save Trace to Database

See Section 8 for information on configuring a database.

1. Import the desired traces onto the workspace.
2. Select a trace.
3. Click on File then Save Trace To Database.

5.10 Renaming Traces

CT Viewer 2 offers two methods for renaming traces. The first covers changing the name of traces
stored within “.mohr” files, and the second method addresses traces stored on a SQL database.
Changing the trace name also changes the actual filename of the trace.

For the purpose of Section 5.10.2, it is assumed that a database connection has already been set up
for CT Viewer 2.

5.10.1 Rename a Trace Stored in a .mohr File
1. Open a “.mohr” trace file.
2. Click on the name of the trace in the information bar (Figure 5.12) at the bottom of CT

Viewer 2. A dialog will appear upon clicking on the trace name (Figure 5.13).

Figure 5.12 The trace name box will change color from pink to red when moused over.

Figure 5.13 The dialog box will appear once the user clicks on the Trace name box.

3. Enter the new name for the trace into the dialog and click the SET button. You will be given
a chance to confirm or reject the name change and overwrite the saved trace. If you click Yes,
the new trace name will be displayed (Figure 5.14) and the filename for the trace will be
changed to the new name.

Figure 5.14 The new name of the trace after being changed in the dialog.
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5.10.2 Rename a Trace Stored in a Database

1. Open the database containing the desired trace by clicking the Open button in the bottom
right of CT Viewer 2 (Figure 5.15) or by selecting File → Open Current Database from the
menu bar. See Working With SQL for instructions on setting up a connection to an SQL
database.

Figure 5.15 The Open button at the bottom right of CT Viewer 2.

2. Select the trace that you wish to change the name of (Figure 5.16).

Figure 5.16 Database with a trace selected for editing.

3. Click on the name of the trace you want to edit under the Trace Label column (Figure 5.17).

Figure 5.17 Clicking on the name of the trace will enable editing.

4. Enter a new name for the trace and press the Enter key (Figure 5.18).
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Figure 5.18 Press enter to immediately save the name to the database.

5. The name of the trace has now been updated within the database.

If the trace is already loaded on-screen, it will need to be reloaded before the name change will
take effect on-screen.

5.11 Changing How CT Viewer 2 Displays Traces (View Menu)

The View menu (Hotkey: Alt-V) contains a host of options to manipulate the way CT Viewer 2
displays traces.

5.11.1 Changing the Horizontal Unit of Measurement

To change the horizontal unit of measurement that CT Viewer 2 uses, click on View then
Horizontal Units. Select the desired unit. See Figure 5.19.

Figure 5.19 The Horizontal Units option is found under the View menu.
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After selecting a new unit type, CT Viewer 2 will recalculate its ruler, and all measurement will be
done in that unit.

5.11.1.1 Nanoseconds Ruler

CT Viewer 2 can display ruler measurements in nanoseconds. Go to View, then Horizontal Units,
then Show NS in Ruler. The ruler will then show nanoseconds as its primary measurement, though
the cursors will be labeled on the ruler with the chosen horizontal unit. See Figure 5.20.

Figure 5.20 The horizontal ruler with measurements in nanoseconds. The cursors are
labeled on the ruler with the chosen horizontal unit, which in this case is feet.

5.11.2 Changing the Vertical Unit of Measurement

To change the vertical unit of measurement that CT Viewer 2 uses, click on View then Vertical
Units. Select the desired unit.

After selecting a new unit type, CT Viewer 2 will recalculate its ruler, and all measurement will be
done in that unit.

5.11.3 Changing the Rendering Mode

The Rendering Mode option can be found under the View → Options menu (Figure 5.21).

Figure 5.21 The Rendering Mode option.
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After a new rendering mode is selected, CT Viewer 2 will use that mode to draw the on-screen
traces.

To change the rendering mode that CT Viewer 2 uses, click on View then Options. Select the
rendering mode you desire. You can choose between rendering with points or lines. See Figure 5.22
and Figure 5.23 for examples of each rendering mode.

Figure 5.22 Line rendering mode.

Figure 5.23 Point rendering mode.

5.11.4 Displaying Extra Grid Lines

To instruct CT Viewer 2 to draw extra grid lines, click on View then Extra Grid Lines. See
Figure 5.24.
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Figure 5.24 Workspace with and without extra grid lines.

5.11.5 Standard Deviation

To display the standard deviation of the selected trace in the Information Box/Cursor
Measurements window at the bottom right, click on View then Standard Deviation (Figure 5.25).

5.11.6 VSWR

To display the voltage standing wave ratio (VSWR) in the Information Box/Cursor Measurements
window at the bottom right, click on View then VSWR (Figure 5.25).

Figure 5.25 The Information Box displaying the standard deviation and VSWR for the
selected trace.

5.11.7 Temperature Display

To display the temperature for the selected trace on-screen, click on View then Temperature
Display. The temperature will be displayed in a small box near the bottom of the screen
(Figure 5.26).
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Figure 5.26 The temperature display for a selected trace.

5.11.8 Vertical Zoom at Cursor Location

To keep the Y value at the cursor fixed when increasing or decreasing the vertical scale (zooming in
and out), click on View then Vert Zoom at Cursor.

5.11.9 Trace Label Options (Alignment and Visibility)

To change the trace label options that CT Viewer 2 uses, click on View then Trace Labels
(Figure 5.27).

Figure 5.27 The Trace Labels options can be found under the View menu.
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With these options, a user can choose how to display the trace name associated with each trace on
the workspace. The default display is set to auto align with traces, but the user can choose a new
default or choose to have the trace names on the current screen displayed at the top right or top
left. Trace names can also be hidden or shown again using this menu, and the display font and font
size for the trace labels can also be changed.

5.12 Annotations

Individual points or a range of points on a trace can be annotated on the CT100B or in CT Viewer
2. Annotations that have been saved on a trace on the CT100B can be viewed, modified, or deleted
in CT Viewer 2. New annotations can also be created in CT Viewer 2.

5.12.1 Annotating Traces

To annotate an individual point on a trace, move the active cursor to that point. If a range of
points on a trace needs to be annotated, move the active and inactive cursors to the starting and
ending points of the range. To create an annotation:

1. Go to Tools then Add New Annotation.
2. Select either Point Annotation or Range Annotation from the drop-down menu. See

Figure 5.28.

Figure 5.28 The annotation drop-down menu.
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A point annotation will be indicated by a single triangle on the trace. A range annotation will have
a triangle at each end of the range with a line connecting the two triangles. Click on a triangle to
view annotation information. See Figure 5.29. The intial annotation indicates the points in
nanoseconds, but this information can be changed. See Section 5.12.2.

Figure 5.29 Annotations and the annotation information box.

Go to File then Save to save the trace with annotations.

5.12.2 Modifying and Deleting Annotations

You can modify or delete annotations created on the CT100B or in CT Viewer 2. Click on an
annotation triangle to bring up the annotation information box. Prior to making any changes,
make sure the Allow Changes box has been selected. See Figure 5.30.

Figure 5.30 Select Allow Changes in the annotation information box before modifying an
annotation.

Replace the current annotation text with the new annotation. Click Set to change the annotation.
To delete an annotation, select the annotation triangle and then click Delete in the annotation
information box. Go to File then Save to save the trace after modifying or deleting annotations.

50 CT Viewer 2 Quick User Guide



5 General Functions

5.13 Math

The Math menu contains a list of special functions that perform calculations on traces. CT Viewer
2 ships with a number of standard functions. The standard set of plugins is shown in Figure 5.31
and described in Table 5.1.

There is a programmer’s API available for users to create additional plugins. Contact MOHR for
more information.

Figure 5.31 The Math menu.

Table 5.1 Math menu options
Menu Selection Purpose/Action
Average Create a new trace that is the average of all selected traces.

Difference Create a new trace that is the difference of two selected traces.

FFT Create a new trace that is the Fast Fourier Transform of the selected
trace.

Phase Create a new trace that shows the phase angle of the selected trace.

Complex Division Create a new trace that is the complex division between two selected
traces.

S-Parameter Create a new trace that is the calibrated return loss plot (S11) of a
selected trace.

Derivative (Slope) Create a new trace that is the slope (1st derivative) of the selected
trace.

Smooth Create a new trace that has a smoothing filter applied to the selected
trace.

The traces displayed by CT Viewer 2 can be divided into two broad categories: time-domain traces
and frequency-domain traces.

Time-domain traces include saved TDR traces. The horizontal axis represents time and distance
with units of nanoseconds and feet or meters.
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Frequency-domain traces include FFT traces, S-Parameter (S11) traces, and phase traces. In CT
Viewer 2, these are always transformations from one or more time-domain traces. The horizontal
axis represents frequency with units of hertz or megahertz.

The two classes of traces have separate pairs of cursors. When a frequency-domain trace is selected,
CT Viewer 2 will switch from the two time-domain cursors to two frequency-domain cursors.

Most Math menu options, such as smooth, will produce a new trace that is in the same domain as
the parent traces. For example, the smooth transformation of an FFT trace is in the frequency
domain. Some Math menu options only work with certain domains. Average, difference, and
derivative traces only give accurate results for time-domain traces. Phase and complex division can
only be used on frequency-domain traces. If you want to find the difference between two FFT
traces, use complex division instead of difference.

The following math functions assume that the operator has loaded a few traces on to the CT
Viewer 2 workspace.

Use Figure 5.32 as the base figure for comparison in the following sections.

Figure 5.32 The primary selected trace (red), secondary selected trace (teal), and
unselected trace (black).

5.13.1 Average

1. Select the traces of interest.
2. Click on Math, then Average.
3. A new trace will be created that is the average of the selected traces (Figure 5.33).
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Figure 5.33 Taking the average of the two teal traces. The new average trace is shown in
red.

5.13.2 Difference

1. Select two traces of interest.
2. Click on Math, then Difference.
3. A new trace will be created that is the difference of the selected traces (Figure 5.34).

Figure 5.34 Taking the difference of the primary (red) and secondary (teal) selected traces.
The difference is shown in blue.

Note: The vertical scale of the new trace is not necessarily the same as the originals. The green
arrows highlight that where the two selected traces intersect, the difference is zero.

CT Viewer 2 Quick User Guide 53



5 General Functions

5.13.3 FFT

Select the trace of interest. Click on Math, then FFT. Enter your choice for window size and
choose from the standard windowing functions in the Options dialog (Figure 5.35). Hann is a
reasonable default windowing function for almost all situations.

Figure 5.35 Options for FFT plugin.

A new trace will be created that is the Fast Fourier Transform of the selected trace (Figure 5.36).

Figure 5.36 Getting the FFT of a cable trace. The FFT is shown in red.
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5.13.4 Phase

This module will generate a phase trace based on a frequency-domain trace. Phase traces can be
created for FFT, Complex Division, and S-Parameter traces. The result is the phase-angle of the
complex value of the trace at each frequency.

1. Select a frequency-domain trace.
2. Click on the Math menu item, and select Phase.

5.13.5 Complex Division

This module will generate the negative complex division between two FFT traces. Use the
following steps to do this.

1. Select two frequency-domain traces with the same resolution.
2. Click on the Math menu item, and select Complex Division.
3. A new trace will be generated that is the negative complex division between the primary

trace and the secondary trace (Figure 5.37).

Figure 5.37 Getting the Complex Division of two FFT traces. The Complex Division is
shown in red.

5.13.6 S-Parameter

The S-Parameter tool will generate a new S11 return loss plot for a specified measured trace. To
use this tool, please use the following steps.

1. Select four time-domain traces. Three of the traces will be used as calibration traces taken
with a short, open, and 50 Ω terminator. The fourth trace will be the measured trace to
generate an S11 return loss plot.

2. Click on the Math menu item and select SParameter.
3. In the pop-up window, identify the short, open, load, and measured trace (Figure 5.38).
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Figure 5.38 S11 Trace Identification window with traces selected for short, open, load, and
measured.

4. Click OK. A new trace will be created that is the S11 return loss plot of the measured trace.

5.13.7 First Derivative (Slope)

Create a new trace that is the calculated slope at each point of the selected trace. The trace will
often amplify subtle features of the original trace.

For example, in Figure 5.39, we can easily see the defects in a 1000′ cable. Inspection of the
physical cable revealed that these perturbations were actually connections in the cable where the
manufacturer had connected shorter pieces to make up the 1000′ length.
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Figure 5.39 Slope of a cable highlighting some defects.

The cursors are on two spikes located at about 156 ft. and 208 ft.

5.13.8 Smooth

Create a new trace that has a smoothing filter applied to the selected trace. The trace is smoothed
by averaging neighboring points. Choosing Smooth will bring up a smoothing options dialog box
(Figure 5.40).
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Figure 5.40 Smoothing options.

There are two things you can adjust in this dialog box:

1. The number of points (the window size) to use in each averaging operation.
2. The algorithm to use. Choose from Radial Filter or Binomial. Both of these are weighted

filters where the center points in the averaging window count more than the ones at the edge.
Radial Filter is the preferred algorithm.
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6.1 Setting up Remote Control

6.1.1 Connecting the CT100B

Connect the CT100B to CT Viewer 2 via Ethernet. For more information on connecting using
Ethernet, see Section 3.2. Remote Control does not work over a USB connection. Once a successful
connection has been made, click on Remote Control then Enable Remote Control (Figure 6.1).

Figure 6.1 Remote Control menu.

CT Viewer 2 will negotiate a live stream with the CT100B. Once a successful handshake has been
made, a live trace will appear on the workspace (Figure 6.2).
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Figure 6.2 The CT100B/CT Viewer 2 connection has been established.

The live trace matches the trace the CT100B is measuring. An operator can use CT Viewer 2 to
manipulate this live trace like any other trace. Any action done to the live trace will also be done
in the CT100B. The live trace will update itself on-screen at a maximum rate of 24 frames per
second.

6.1.2 Assistant Mode

After a valid CT100B/CT Viewer 2 connection has been made and a live trace is on the workspace,
the CT100B is in a screensaver mode. Assistant Mode allows the trace to be displayed on the
CT100B screen simultaneously with the trace in CT Viewer 2. Controls on the CT100B (such as
Vp adjustments and horizontal and vertical scale and position changes) as well as the controls in
the CT Viewer 2 program can be used to manipulate the trace. Any action done on the live trace
in CT Viewer 2 is reciprocated over to the CT100B. This way the operator on each end will be
viewing the same region of the trace. This mode can be useful for providing remote support to a
CT100B user.

Turning on Assistant Mode will slow the maximum frame rate that the CT100B can transfer to the
CT Viewer 2 software. To turn Assistant Mode off, simply uncheck it on the Remote Control
menu.

6.1.3 Disconnecting Remote Control

To disconnect Remote Control, click on Remote Control then RC Disconnect. Remote Control will
disengage, leaving the live trace on the CT100B updated to reflect any actions done to it in CT
Viewer 2.

Note: After disconnecting Remote Control, CT Viewer 2 and the CT100B are still connected.
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6 Remote Control

6.2 Overview

6.2.1 Adjusting Frame Rate

To change the frame rate in which data from the CT100B is sent, click on Remote Control then
Adjust Frame Rate (Figure 6.3).

Figure 6.3 The Adjust Frame Rate option under the Remote Control menu.

Generally, an operator would want a faster frame rate when recording a time slice. Normally the
frame rate should be slower, skipping a larger number of frames between transmissions.

6.2.2 Live Trace Smooth Mode

CT Viewer 2 can smooth (average) the incoming frame data to a specified sample range, much like
how smoothing can be set from 1x to 1024x on the CT100B. For example, choosing a smoothing
mode of 64x will instruct CT Viewer 2 to average the past 63 frames with the current frame.

By default, the smooth mode is set to 1x. To change the smooth mode, click on Remote Control
then Live Trace Smooth Mode and select the desired sample size (Figure 6.4). Note: Changing the
Live Trace Smooth Mode sample size is not reflected on the CT100B.
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Figure 6.4 Changing the smooth mode with the Remote Control menu.

Higher frame rates will allow a faster smoothing calculation. See Section 6.2.1 for help on changing
the frame rate.

6.2.3 Recording a Movie (Time Slice)

Select Record To Movie File from the Remote Control menu. This will bring up a Save As dialog
box. Give the movie file a name. It will automatically be set to save in the default folder as chosen
by Set Default Trace Folder in the File menu, though you can choose a different location to save
the movie file to. (See Section 5.8.1 for more information on the default trace folder.)

Once you click Save, recording begins. When you are finished, select the Stop option under Remote
Control (Figure 6.5).
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Figure 6.5 Record To Movie File and Stop options under the Remote Control menu.

While recording is active, it is indicated by the RECORDING label next to the live trace
(Figure 6.6).

Figure 6.6 CT Viewer 2 is recording data from the CT100B.

After you have completed recording and selected Stop, you can load the movie trace into the
workspace. Use the File → Open Other Files menu and select the filename that you created
(Figure 6.7 and Figure 6.8).
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Figure 6.7 Selecting a movie trace to load into the workspace.

Figure 6.8 The movie trace has just been loaded.

6.2.4 Navigating a Movie (Time Slice)

Navigating a movie (time slice) is done by instructing CT Viewer 2 to render the specific frame
that you are interested in.

The trace label of a movie file displays what frame of the movie you’re currently on and how many
frames are in the movie (e.g., 1/1168), as well as a time stamp for the frame in seconds.

You need to have the movie trace selected in order to use the actions under the Movie option in
the Tools menu (Figure 6.9).
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Figure 6.9 Movie sub-menu.

6.2.4.1 Next Frame

1. Select the trace with the mouse. This will turn the trace red.
2. Press the period key on the keyboard.
3. CT Viewer 2 will update the trace to reflect the next frame of the trace.

6.2.4.2 Previous Frame

1. Select the trace with the mouse. This will turn the trace red.
2. Press the comma key on the keyboard.
3. CT Viewer 2 will update the trace to reflect the previous frame of the trace.

6.2.4.3 Goto Frame #

1. Select the trace with the mouse. This will turn the trace red.
2. Go to Tools → Movie → Goto Frame #.
3. Enter a frame number in the dialog box and click OK.
4. CT Viewer 2 will update the trace to reflect the chosen frame of the trace.
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7 Keyboard and Mouse Help

Pressing the spacebar in CT Viewer 2 will bring up an illustration of keyboard and mouse
shortcuts (Figure 7.1). Pressing the spacebar again will remove the illustration from the screen.

Figure 7.1 Pressing the spacebar brings up keyboard and mouse shortcuts.

Table 7.1 Keyboard help
Keyboard key Action
Tab Select the next trace in the list.

Q Decrease m/ft per division (X-scale)

E Increase m/ft per division (X-scale)

-, _ Decrease rho per division (Y-scale)

+, = Increase rho per division (Y-scale)

W, Up Arrow Move all traces up. (Pan up)

S, Down Arrow Move all traces down. (Pan down)

A, Left Arrow Move all traces left. (Pan left)

D, Right Arrow Move all traces right. (Pan right)

Delete, Backspace Delete selected traces.

Shift Modifier for moving traces relative to each other (up-down only)

Ctrl Modifier for moving traces relative to each other (left-right only)

Shift + Ctrl Modifier for moving traces relative to each other (free movement)

, With a movie trace selected: Go back one frame.
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Table 7.1 (Continued) Keyboard help
Keyboard key Action

. With a movie trace selected: Go forward one frame.

~ Toggles between pan and select tools.

F1 Opens the online Help menu.

Table 7.2 Mouse help
Mouse Action
Left Button Move all traces. (Pan with mouse movement)

Right Button Drag a zoom box over a trace. The trace will be zoomed in on the
region selected by the box.

Shift Modifier for moving traces relative to each other (up-down only)

Ctrl Modifier for moving traces relative to each other (left-right only)

Shift + Ctrl Modifier for moving traces relative to each other (free movement)

Alt Modifier to change Y-offset of selected trace.

Mouse Wheel (Up) Decrease rho per division (Y-scale)

Mouse Wheel (Down) Increase rho per division (Y-scale)
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8 Working With SQL

Working with SQL is optional and only recommended if the user has previously used CT Viewer 1
and has databases from previous use that they would still like to use in CT Viewer 2.

8.1 Configuring the Database

To configure a database for CT Viewer 2 to use, click on the Select a Connection button at the
bottom of the display window (Figure 8.1).

Figure 8.1 The Select a Connection button at bottom of the display window.

Choose Add a New Server from the menu. This brings up a dialog box (Figure 8.2).

Figure 8.2 The Add a Server dialog box.

If you have an SQL Express installation on your PC, you can just click Test Connection. If you
don’t have a local installation, enter the server name or IP information for your network SQL
server and then click Test Connection. If Test Connection succeeds, a dialog will ask if you want to
add the server to your list. Choose OK and close the Add a Server dialog. Now click again on the
Select a Connection menu and choose the connection that you just created (Figure 8.3).
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Figure 8.3 Choose your SQL connection.

Now that you have chosen an SQL server connection, the Select a Database button will populate
with the list of databases available from that server. Choose the database that you wish to use or
select the Create Empty Database option (Figure 8.4).

Figure 8.4 Choose a database from the SQL server.

Now that you have a database selected, there are two database commands in the File menu
available to you, Open Current Database and Save Trace to Database (Figure 8.5).

Figure 8.5 File menu with database options.

8.2 Loading Traces From a Database to the Workspace

Click on File then Open Current Database (Hotkey: Ctrl-B).
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Clicking on this item will open a database window displaying a list of traces contained in the
current database.

Figure 8.6 An example of a database overview.

Figure 8.6 shows the result of the Open Current Database command. Select a trace by clicking on
rows in the table. Use Shift-click or Ctrl-click to select additional traces. The buttons across the
top of the window are used to perform different actions on the selected trace(s). These are
described in Table 8.1.

Table 8.1 Database functions
Menu Selection Purpose/Action
View Trace Load the selected traces onto the workspace.

Refresh Reload the database to see if any new traces have been added since
the last refresh.

Copy To Copy the selected traces to another database.

Export > XML Export the selected traces to an XML file.

Export > MOHR Export the selected traces to a .mohr formatted file.

Search For very large databases, the search capability can be used to search
for traces by name, source machine ID, date, or velocity of
propagation.

Delete Remove the selected traces from the database. This will remove them
permanently.

Exit the database overview by pressing the X button on the top right corner of the window.

8.3 Saving Traces in a Database

Traces that are displayed in CT Viewer 2 can be saved as .mohr files or can be saved in a database.
Use File → Save Trace to Database, and the currently selected trace is added to your database.
Click the Refresh button to see that the trace has been added to the collection. See Figure 8.7.
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Figure 8.7 After adding several traces to the database.
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